edited June 2018 in ORK Support
Hi, I just upgraded to Ork 2.16, and Unity 2018. I like it so far. However, I cannot make my real time battles work with my fire spell. My other spells, Heal, and Mana Renew.. work correctly except no sound. They are self target. but no matter what I do, the fire spell icon is grayed out or transparent in the list of spells, then when i drag it to my shortcut hotkey menu, it is still transparent where the heal and mana spells are solid black background.

I tried a total zone real time battle area, then I tried just a smaller area battle area. No luck. I use abilities and an item of the spell for the ability. You create the spells, and the spell casts the ability when it is put onto the skillbar.

Also. I just used evil pants and he killed me, but I cannot damage him with my grayed out spell.

I hope I made sense.

My first person character controller has :

character controller
first person controller
damage dealer
damage zone

Below are screenshots of all of my settings. Please click to zoom in. The first is the ability settings "fireclaws" attack.
The second is the "fireclaws" spell that casts the fireclaws ability.
The third is the Fireclaws battle event I use. The last image in this post, is a screenshot of a save game error I get.

Thank you. any help greatly appreciated.

fireclaws ability settings


fireclaws spell settings


and finally, the fireclaws battle event.




Post edited by silverglade1 on
  • I think you reversed use cost and target changes - in your setup, the use cost are calculated using the magical damage formula, while the target changes just subtract 5 from HP. I guess the magical damage is just higher than your combatant's MP, making the ability not useable due to the use costs.

    Check your settings in Menus > Save Game Menu and save afterwards, might be that something isn't initialized correctly.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited June 2018
    Thank you so much for that GiL. My save works correctly now. However, my "fireclaw" spell only works when i set the target to myself. i cannot figure out how to not have the spell grayed out in my inventory and skillbar when i set target to enemy.
    Also, when i pick of a collectible item on the ground, the "OK" button covers the message to me,

    EDIT: Just tried this morning for fireclaws again, did the tutorial here


    no luck. Still, no matter what I do, the spell will only cast if the target is myself. The spell grays out and is uncastable if target is enemy,
    Post edited by silverglade1 on
  • Can you post the target settings of your spell item?
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • edited June 2018
    Hi GiL. Thanks very much for helping. Ok, Here is my "fireclaws spell item" settings pic. Note: the target is currently self, to show you what settings work, that I had to put the target as "self". When I put the target for spell and ability as "enemy", the spell icon is grayed out and won't cast in game.

    Also 1 other thing , the OK button is over the item pickup message.

    Below. Fireclaws spell item settings.
    Please click to zoom.


    and here is my "fireclaws ability" that the spell uses settings pic.


    and here are pics of the calculateEffectTarget2.asset and Cast events both use.

    event settings

    pic 1 cast


    pic 2 calculateeffecttarget2


    pic 3 calculate effect target 2 pic 2


    Thank you GiL. :-)
    Post edited by silverglade1 on
  • Well, my best guess would be the use range of the item (or default use range if it doesn't override it).
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • LOL GiL. once again you saved my game. I am pretty sure I can continue it now. Do you know how to get the OK button moved so that it is not over the Item collection text when I pick up an item? Please. It says "You have found X", and the OK button is over it.

    Thank you so much. You solved it.
  • The default settings for the ok/cancel buttons are in Menu > Menu Settings in the Default GUI Box Settings. Each GUI box can override these settings :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.