Hello,

I am running into an issue where the character starts stuttering because it interrupts the run animation with the idle animation. For reference, I did a quick recording:
https://drive.google.com/open?id=15BHJySn6LrbT9TZLkr6OiRtVFPUfV2b8

For set up, I followed along exactly (granted using different animations) with the mecanim tutorial, and so far my google searches haven't turned up anyone else running into the issue.

Do you know what might be the issue?

Thanks!

Will
  • edited June 23
    As far as I know looping mecanim animations can't have transitions using Ork. Instead remove them and use the Crossfade option in the animations tab, for instance I use a Crossfade of 0.3 seconds for my idle and it works almost as well as a mecanim transition.

    I did that too at first and got the same stutter.Every time it'd go to loop the walk animation it would run through the transition first, play the idle, then play the walk again.
    Post edited by Wrofir on
    Warborn
  • Which transitions specifically? Following with the tutorial, my Walk and Run do not have any transitions to them. Idle does have transitions from Entry and the various Triggers though.

    I do have Idle, Walk and Run to all be a Play Mode of CrossFade with 0.1 seconds. They also have a duration of 0 if that's relevant?
  • Do you have the "Position change(?)" checkmarked on the auto animation and on the prefab?
    It seems to be having trouble knowing if the prefab is moving or still.
    Warborn
  • edited June 24
    I did not, but checking that hasn't seemed to have an effect. Currently my prefab just has the Animator and Character Controller components on it and that's all.

    Here's my animation settings as well:

    image

    I appreciate you taking the time to help!
    Post edited by Acissathar on
  • Are the animations actually set up to loop?

    You can also try to set up the movement animations as transitions with parameters instead of playing them, e.g. using a Bool parameter, in which case you need to set up both start and stop parameter changes in ORK.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • The animations were set to loop, but it looks like I totally skipped the big troubleshooting section underneath your Mecanim Animations tutorial.

    The part where it specifically says "stuttering movement" and to mess with the run/sprint thresholds. Changing those values have fixed the stuttering and I can't believe I missed it.

    Thanks for your time everyone haha
  • Haha, totally forgot that could also be an issue :)

    Generally, I'd recommend sticking with the legacy animation system, unless you're forced to use Mecanim (e.g. your models already coming with that setup). The legacy system allows a lot more control (also for ORK) and makes less of a headache.

    When using Mecanim, don't forget to define a Duration in your ORK animation setup, as otherwise the Wait options in events don't work due to Mecanim having no way to tell how long an animation takes ...
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • When using Mecanim, don't forget to define a Duration in your ORK animation setup, as otherwise the Wait options in events don't work due to Mecanim having no way to tell how long an animation takes ...
    That explains a few things... lol
    Warborn
  • Yeah ... might need to add a more prominent warning in the Mecanim animation setup :)
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.