edited July 2019 in ORK Support
Hi. I have a problem with attack in Real Time Battles. Everything for fine before, and now something like this happens - attack animation don't play, I can't do damage to enemy, enemies can't fight too... I check everything - input, animations, combatants, battle events, control maps... Nothing block control maps, everything is normal. I also have Real Time Battle Area for Whole Scene and I check if this happens in Limited Area - same thing. What is wrong? Please for help and thanks :)

Oh, and I Can use Skillbar also - I can drink potions, cast spells (and spell can kill enemy). But for some reason only the attack don't work.
Post edited by MarcioHan on
  • Did you attach a damage dealer and rigid body components to your weapons? And a damage zone to your combatants?
  • Yes, everything is there. That's why I don't know what's wrong. I read tutorials again, I check battle events etc.
  • Post a pic of your weapon, and attack set up so I can take a look if you can.
  • edited July 2019
    Well if the attack animation isn't playing it sounds like the attack event isn't firing off at all.
    Did you accidentally remove the event from the Attack abilites battle animation?
    Post edited by Wrofir on
    Shadowcaste
  • No, I have Attack battle event in Atack Abilities. It's just weird, I made this event based on GIL's tutorials and everything is the same in there.
  • Sounds like the attack isn't fired at all, so check if:
    - the control map firing the attack can be used in your real time battle
    - the combatant you're controlling has the control map
    - the attack can be used (e.g. use costs, requirements, etc.)
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
  • Ok... Weird. My enemy is "Zombie". So I just spawn not my "Zombie" but "Evil Pants". And "Evil Pants" works! I Can fight without problem. I Can't fight with my "Zombie" enemy and I Don't know why. I check the prefab - everything is the same like in Evil Pants. I check in Combatants - same. I'm going to try just copy the Evil Pants prefab and switch with my "Zombie" and see how this will work.
  • edited July 2019
    Here how it looks in Editor. If i'm standing on Zombie's Head - I Can hit him and I Can fight with him, but on the ground nothing happends :P



    So, I guess... The problem is in my Zombie character model?
    Post edited by MarcioHan on
  • Try increasing the use range of the attack ability?
    Shadowcaste
  • Uhh Thank you! It works! With Battle Area it works fine. Without Battle Area, I need to jump on enemy head and then he Can attack me, but it's not a problem ;) Thank you very much! :)
  • Also, keep the Box Radius setting of your combatants in mind - if your enemy is larger (e.g. collider), you need to increase that as well. The box radius is also taken into account in range checks, so that the range starts at the end of the radius.
    Please consider rating/reviewing my products on the Asset Store (hopefully positively), as that helps tremendously with getting found.
    If you're enjoying my products, updates and support, please consider supporting me on patreon.com!
Sign In or Register to comment.